【WordPress日本語版】Composer detected issues in your platform の解決方法

WordPressのエラー:Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.で困っていませんか?

私は、当サイトもそうですがその他にもいくつかサイト運営しています。

その中の一つのサイトが以下のエラーを表示させて、トップページ以下の全ページが表示されなくなってしまいました。

Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.

Google翻訳で日本語に翻訳してみると以下の内容でした。

Composerがプラットフォームで問題を検出しました:Composerの依存関係にはPHPバージョン “> = 7.3.0″が必要です。

当ページに訪問いただいた方の中にも、同じようなエラーメッセージが表示されているかもしれません。

そこで今回は、「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」が表示されて困っている人向けの解決方法となっています。

スポンサードサーチ

PHPバージョンエラーを解決できればトラブルの参考になる

結論をお伝えしますと、今回の「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」は、PHPのバージョンに関する問題でした。

もし、同じ問題を抱えて当ページへ訪問した方なら、このまま読み進めていただければ以下の様な経験が出来ると思います。

サイトの表示が元通りになる

引き続き読み進めていただければ、「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」が表示されてサイトが表示されなくなったエラーを皆生する事が出来ます。

解決方法も2つ紹介していますので、どちらかがダメでも諦めずに試してみてください。

きっと、いつものサイトが表示されると思いますよ。

WordPressのエラーが出た時の参考になる

今回経験したWordPressのトラブルは、数有るトラブルの中の一つです。

私もこれまでに何度もサーバーエラーやPHPエラーの経験をしました。

なので、今回は早期に解決する事が出来ました。

皆さんもこういったエラーが有るという事を覚えておくだけで、同じようなWordPressのトラブルが起こった時の参考になると思います。

なので、これからお伝えする今回の「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」エラーの解決方法を読んで、是非知識として覚えておいて損は無いと思いますよ。

という事で、どうやって解決したかをお伝えしていこうと思います。

Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.の解決方法

なぜ「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」が表示されてサイトが表示されなくなったのか?

その原因と解決方法を順番にお伝えしていきます。

プラグインのアップデートタイミングで発生していた

今回、このエラーが表示されたタイミングは、特定のプラグインをアップデートしたタイミングでした。

そのプラグインとは、「delete-duplicate-posts」です。

「delete-duplicate-posts」の解説はこちらでやっています。

Delete Duplicate Posts:WordPressで重複記事をチェックして自動で削除
WordpressプラグインのDelete Duplicate Postsの初期設定や使い方を解説しています。重複タイトルや重複記事を一括で自動削除してくれるDelete Duplicate Postsのメリットをわかりやすく解説しています。

このプラグインは、重複した記事を削除してくれるプラグインです。

恐らく、プラグインのアップデート時に最新バージョンを使う為のPHPの最低バージョンをクリアしていなかったのが原因じゃないかと思います。

なので、具体的な解決方法は恐らくこの2つに絞りました。

PHPのバージョンアップを7.3以上にバージョンアップする
原因となるプラグインを削除する

という事で、上記2つのやり方をこれから紹介していこうと思います。

PHPのバージョンをアップデートする方法

まずは、PHPのバージョンをアップデートする方法を紹介します。

複数のレンタルサーバーを契約しているのですが、「エックスサーバー」と「ジェットボーイ」を例にそれぞれ紹介していくので、参考にしてください。

エックスサーバーのPHPバージョンアップ方法

事前にレンタルサーバーのログイン情報を準備しておいてください。

後は、フロー通りにやれば出来ると思います。

  1. サーバーパネルへログイン
  2. 「PHP>PHP Ver.切替」を押す
    エックスサーバー>サーバーパネル
  3. 「ドメイン選択画面」でバージョンアップする「ドメイン」を選択
  4. 「変更後のバージョン」を選択して「変更」を押す
    エックスサーバー>サーバーパネル>PHPバージョン切替1
  5. サイトが正常に表示されているのが確認できれば完了です
  6. エックスサーバー>サーバーパネル>PHPバージョン切替2

いかがでしたか?

私も使っているエックスサーバーでPHPバージョンアップは、比較的簡単だったと思います。

もし、エックスサーバーについて興味が有る方は、こちらをご覧ください。

エックスサーバーが大幅増強!契約するなら今しかない 2020年5月版
国内最速レンタルサーバーのエックスサーバーが大幅増強されました。データベース数やメモリ数が大幅増強されたので解説します。エックスサーバーの評判も掲載していますので、参考にしてください。

ジェットボーイのPHPバージョンアップ方法

サブサイトで使っているレンタルサーバーのジェットボーイでのPHPバージョンアップ方法を解説していきます。

  1. サーバーパネルへログインします
  2. 「ソフトウェア>PHPバージョン変更」を押します
    ジェットボーイ>サーバーパネル
  3. PHPバージョンアップしたい「ドメイン」を選択します
  4. 「PHPバージョン」を選択して「適用」を押します。
    ジェットボーイ>サーバーパネル>MultPHPマネージャー
  5. サイトが正常に表示されているのが確認できれば完了です

いかがでしたか?

こちらも、比較的簡単にできたと思います。

エックスサーバー程の高スペックでは有りませんが、低価格で使えるレンタルサーバーなので現在も契約中です。

ジェットボーイについて興味が有る方は、こちらをご覧ください。

ジェットボーイの評判と体験談 WordPressのレンタルサーバー選び
クラウド型レンタルサーバーのジェットボーイのメリットや評判を紹介しています。ジェットボーイが何故選べるているか?人気なのかをサービス内容や料金プラン度を紹介しながら解説しています。

きっかけとなったプラグインを削除する

PHPバージョンアップで、「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」の問題が解決できた方は、おめでとうございます!

そして、解決できなかった方は、これから解説する方法を試してみてください。

もし、プラグインのアップデート途中で「Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.3.0”.」が表示されてしまった場合は、どのプラグインをアップデート中になったのか?思い出してください。

例えば、私の場合は「Delete Duplicate Posts」というプラグインでした。

なので、レンタルサーバーのファイルマネージャーやFTP経由で「Delete Duplicate Posts」フォルダをリネームし、一旦使えない状態にします。

もし、このきっかけとなったプラグインを使えない状態にする方法で解決できたのであれば、プラグインが問題という事になります。

表示が正常に戻った状態のまま、「WordPressダッシュボード>プラグイン>インストール済プラグイン」で該当プラグインを「削除」しましょう。

もし、ファイルマネージャーやFTP経由で該当プラグインを探す時は、以下のフォルダ階層を参考にしてください。

wp-content > plugins > delete-duplicate-posts のフォルダ名をdelete-duplicate-posts_NO に一時的に変更する

もし、当該プラグインがどうしても必要なら一度削除したのちに、再インストールするのをおすすめします。

スポンサードサーチ

結論:レンタルサーバーは最新のPHPが使える所にしましょう

今回解説したエラーの解決方法のメインは、PHPのバージョンアップでした。

しかし、レンタルサーバーによっては最新のPHPバージョンを利用できないものも有ります。

理由としては、サーバーの調整に手間がかかってしまうからです。

なので、レンタルサーバーを契約する際は、最新のPHPバージョンに対応しているかを必ず確認するようにしましょう。

現在メインで利用しているレンタルサーバーは、エックスサーバーなんですがここなら最新のPHPバージョンを使い続ける事が出来ます。

もし、レンタルサーバーで悩んでいる方は、是非一度試してみてはいかがでしょうか。

公式サイトでエックスサーバー無料お試しを申し込む方はこちら

もし、WordPressに関してその他の問題で困っているなら、以下が参考になるかもしれません。

興味が有ればご覧ください。

【WordPress】WARNING: COUNT(): PARAMETER MUST BE AN ARRAY… が表示された時の対処法
Wordpressサイトでヘッダーの下にWARNING: COUNT(): PARAMETER MUST BE AN ARRAY OR AN OBJECT THAT IMPLEMENTS COUNTABLE IN~が表示されるエラーが発生した際の解決方法を紹介しています。PHP7.2以降で良く発生するWARNING: COUNT()のコードエラーで困っている方に参考になりますのでご覧ください。
WordPressサイトが不正ログイン&コード改ざん解決方法
WordPressサイトが不正ログインされて、ソースコードが不正に改ざんされた時の体験談と解決方法を紹介しています。同じように不正ログインされた方の参考になると思います。

 

タイトルとURLをコピーしました